AutoIt Français

Nouveau forum : http://www.autoitscript.fr/
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexionhttp://www.autoitscript.fr

Partagez | 
 

 le mp3 ?(RESOLU)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: le mp3 ?(RESOLU)   2007-03-18, 13:58

tout est dit dans le titre, mon premier script était un lecteur audio mais je m'aperçois que le pm3 n'est pas lu et vu que je débute je comprend pas trop pourquoi(je me doute un peu que sa soit être une histoire de dll, j'ai xp d'origine, j'ai pas de mplayer, c'est xp light), j'avais essayé aussi en vb6 mais le resultat est pareil.fut aidé par le livre ..(la dll mci)

y a une dll de prévu sinon ?

en même temp au niveau des radio du net sa fonctionne pareil ?


merci de m'aiguiller


Dernière édition par le 2007-03-20, 01:35, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 18:30

Tiens ? connaissais pas ce format.
As tu essayé de l'ouvir avec la dll "winmm.dll" qui lit une bonne partie des format audio / video ?

exple d'utilisation :

[code]
$video="I:\video\Lamu.avi"
mciSendString("open "&$video&" alias myvideo")
$dureemilli = recupdureevideo()
mciSendString("play myvideo from "&0)
MsgBox(0,"debug",$dureemilli)
Sleep($dureemilli)
mciSendString("close myvideo")
Func mciSendString($string)
Local $ret
$ret = DllCall("winmm.dll","int","mciSendString","str",$string,"str","","int",65534,"hwnd",0)
If Not @error Then Return $ret[2]
EndFunc

;Fonction de récupération de la durée d'une vidéo
Func recupdureevideo()
Local $ret
mciSendString("set myvideo time format milliseconds")
$ret=mciSendString("status myvideo length")
If Not @error Then Return $ret
EndFunc
[/code]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 18:52

winmm.dll","int",">>mci<<SendString



oui c'est bien çà mais il prend pas en compte le mp3
y a pas mal de format ou peut-être que je ne suis pas à jour.

'y a une dll concut >> FMOD'

si pas.... comme on dit tanpis
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
VooDoo
Modérateur
Modérateur


Nombre de messages : 161
Date d'inscription : 11/12/2006

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 22:18

Mais ou allez vous
[b]Soundplay() [/b]:D il ne fait pas le mp3 ? mais si !

[color=Red]#include[/color] <Sound.au3>
[color=MediumBlue]$sound[/color] [color=Green]=[/color] _SoundOpen ( [color=Fuchsia]@scriptdir[/color] [color=Green]&[/color] "/*.mp3" )
[color=MediumBlue]$Taille[/color] [color=Green]=[/color] [b]_SoundLength[/b] ( [color=MediumBlue]$sound[/color] )
_[b]soundplay[/b] ( [color=MediumBlue]$sound[/color] )
[color=Green]While[/color] 1
[b]traytip[/b] ( "LEcteur windows media player 12 xD" [color=Green],[/color] [b]_SoundPos[/b] ( [color=MediumBlue]$sound[/color] ) [color=Green]&"[/color] / " [color=Green]&[/color] [color=MediumBlue]$Taille[/color] [color=Green],[/color] 0 )
[color=Green]if[/color] [color=MediumBlue]$Taille[/color] [color=Green]=[/color] [b]_SoundPos[/b] ( [color=MediumBlue]$sound[/color] ) [color=Green]then[/color] [b]exit[/b]
[b]sleep[/b] ( 100 )
[color=Green]WEnd


[/color]Sinon c'est que ton fichier est mal codé ![color=Green]
[/color]

_________________
[img]http://img87.imageshack.us/img87/7941/autoit6oy.jpg[/img]
[url=http://autoit-fr.realbb.net/AutoIt-v3-c2/Entraide-f5/Regles-t39.htm][i]Lisez les règles ou soyez maudit ![/i][/url]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 22:30

heu tu parle du fichier mp3 ? car la solution du script est a l'identique ... enfin c'est surement la dll qui n'est pas a jour vu que je dispose pas de mplayer..
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
VooDoo
Modérateur
Modérateur


Nombre de messages : 161
Date d'inscription : 11/12/2006

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 22:34

Oui je parle du fichier mp3.

[quote] car la solution du script est a l'identique[/quote]

Quel solution ?

Sinon quel est le format de tes fichiers mp3 ?

_________________
[img]http://img87.imageshack.us/img87/7941/autoit6oy.jpg[/img]
[url=http://autoit-fr.realbb.net/AutoIt-v3-c2/Entraide-f5/Regles-t39.htm][i]Lisez les règles ou soyez maudit ![/i][/url]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-18, 22:55

heu ... on parle de mp3 ou de pm3, car les deux éxistent.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-19, 01:27

j'ai testé et c'est toujours pareil (il li bien le wav) mais rien en mp3 me fait une erreur fatale :'(
[color=green][/color]Tanpis et niveau stream vous avez quelque chose ?

pour la lecture de lien tel que cela ?

;http://cache.yacast.fr/V4/nrj/nrj.asx
;http://www.tv-radio.com/station/rfm/rfm-20k.asx

ou en lien winamp ? stream video/music


connait pas le pm3 (hé hop recherche) mais je comprend pourquoi tu le demande je devais etre fatigué (le titre c'est bien mp3 et pas pm3 ^^' )
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-19, 21:31

tu peux nous fair un copier / coller de l'erreur fatale pour voir ?
Et ça te le fait pour tous les mp3 ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-20, 01:06

oui le format n'est pas prit en compte et je n'ai pas pu tester sur le format video vu que je n'en dispose pas.

1. j'ai rien comme plugin ogg divx ect
2. je ne dispose pas de mplayer (wmp)
3. la taille de la dll (winmm) fait 177ko date de modification le 4/08/2004 << et vous ?

la je part tester sur une machine qui dispose d'un windows media player.. je vous dit quoi.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-20, 01:12

jeudi 29 août 2002, 11:45:06
version 5.1.2600.1106
172 ko
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-20, 01:29

ok, bon ca fonctionne toujours pas, j'ai meme recup sa dll et rien .. le programme s'eteind automatiquement, bon je vais voir avec la dll [url=http://www.fmod.org/]FMOD [/url] (free free, open source)

y a du stream d'après la lecture (mais sa sera pas pour aujourdh'ui ni demain trop novice je suis)

merci quand meme
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-20, 01:38

[quote:f5a1="ani"]
ok, bon ca fonctionne toujours pas, j'ai meme recup sa dll et rien .. le programme s'eteind automatiquement...
[/quote]

Quand tu dis s'éteind automatiquement, c'est que ça se termine avec une erreur critique genre croix rouge, ou c'est simplement l'appli qui se ferme.
Si c'est le deuxième cas, c'est peut être que tu ne lance pas une boucle assez longue pour laisser le morceau jouer.

Sinon, je viens de revoir le script que j'avias posté, et tins à préciser que si il y a un espace dans le nom du fichier, ou son chemin d'accès, alors ça capote. il faut mettre le bon vieux chemin à la DOS avec des ~
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: le mp3 ?(RESOLU)   2007-03-20, 01:51

en faite j'ai essayé d'autre lecteur déjà tout fait et ... pareil en mp3 il close l'appli (y a une erreur dans le module de l'appli la superbe croix rouge (le titre erreur d'application) le message habituel :: l'instruction à " 0x" emploi l'adresse memoire "0xffffffff" la mémoire ne peut pas être "read" (lu)

autoit lui me sort juste comme quoi l'ouverture du fichier est ok mais il close l'application ... je penche plutot sur une dll que j'ai surement pas install (avec l'ogg/xvid ect) , vu que j'ai winamp j'ai jamais pu trop fait attention..
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: le mp3 ?(RESOLU)   Aujourd'hui à 16:30

Revenir en haut Aller en bas
 
le mp3 ?(RESOLU)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Roll-over (Resolu)
» icone(RESOLU par Migau)
» Le message ne se postent pas...[RESOLU]
» [RESOLU] Bidouillage
» Modérateurs couleur groupe RESOLU

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
AutoIt Français :: AutoIt v3 :: Entraide-
Sauter vers: