AutoIt Français

Nouveau forum : http://www.autoitscript.fr/
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexionhttp://www.autoitscript.fr

Partagez | 
 

 Probleme pour lancer un menu

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Probleme pour lancer un menu   2007-05-29, 23:28

Bonsoir,

Je suis un élève de DUT informatique 2eme année..je suis actuellement en stage en entreprise de fin d'année

Le directeur de la boite m'a donné une mission : Il veut que je lance grace a auto It l "gestion de l'ordinateur" pour permmetre à l'utilisateur de se laisser guider et de juste entrer les informations le reste c'est auto it qui s'en charge

Or le menu est de type "Document de Console COmmune Microsoft " j'avais utilisé l'extension je ne me souviens plus mais elle ne marchait pas !!

Donc ma question est comment lancé ce menu via Auto IT

Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 00:04

[quote:ad80="Nicolas"]Bonsoir,

Or le menu est de type "Document de Console COmmune Microsoft " j'avais utilisé l'extension je ne me souviens plus mais elle ne marchait pas !!

[/quote]

compmgmt.msc ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 00:20

Merci de m'avoir répondu,je me souviens que c'était cette extension que j'ai utilisé mais elle ne marchait pas bizzarment.

Je ne suis pas actuellement dans l'entreprise,pour mettre ici le message d'erreur,je mettrais ça demain !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 00:28

Ma question n'en était pas vraiment une ^^
ça tourne autours de ceci.
En attendant, je vais te donner une piste, car ceci reste quand même ton projet de stage, donc une part de recherche perso est nécessaire ^^

il faut juste trouver la syntax de lancement de ce fichier, et la faire executer avec Run, dans le même répertoire de travail indiqué qq part. (le panneau de config est ton ami ...)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 12:15

Je suis au boulot

J'ai copié le fichier de gestion de l'ordinateur dans le fichier même,je le lance manuellement il marche

Voici mon code qui tiens en une ligne

Run("compmgmt.msc")

Malheureusement il me dit : Line 13 cette ligne

Error : Unable to execute the external program pourtant le gestion de l'ordinateur se trouve dans le meme repertoire que le programme !! Il n'est pas externe

Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 12:46

Salut Nicolas,
A ce moment là faut utiliser la commande secondaire, comme suit:

[b]run[/b]([color=magenta]@ComSpec[/color] [color=red]&[/color] [b]'[/b] /c compmgmt.msc[b]'[/b][color=red],[/color][color=black][b]""[/b][/color][color=red],[/color][color=magenta]@SW_HIDE[/color])

le [color=#ff00ff]@SW_HIDE [/color][color=#000000]permet juste de cacher la fenetre ms-dos.[/color]

ou tout simplement
[b]ShellExecute[/b]('compmgmt.msc')
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 12:54

Merci beaucoup Ani c'est la commande que je cherchais !!! =)

il faudrait que je recherche un tutoriel en Francais sur internet pour avoir le maximum de commande possible car je pense que je vais faire face a pas mal de nouvelles choses
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 13:03

[quote]il faudrait que je recherche un tutoriel en Francais sur internet pour avoir le maximum de commande possible car je pense que je vais faire face a pas mal de nouvelles choses[/quote]

hm en même temp j'avais pas lu la réplique de sylvanie

quel cmd ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 14:30

Pour l'instant je ne sais pas

Par exemple dans comment cocher les checkbox sans echainer les tabulations !

Car quand j'automatise je le fais grace au touche du clavier !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 16:35

Les commandes que je demande sont par exemples comment acceder au menu juste en dessous du titre qui comporte 'Ficher' ,'Edition','affichage',favoris" etc etc sans déplacer la souris?

je vais consulter la doc fourni avec Auto It mais il me semble qu'on peut utiliser des raccroucis or gestion de l'ordinateur non
...

EDIT : c'eset pas tres intélligent mais en tapant toutes les touches du clavier j'ai trouvé c'est F10 , Send("{F10}") est t-elle une commande valide?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-30, 22:46

Pour la commande ,point de grosse recherche, suffisait d'éditer le raccourics "Gestion de l'ordinateur" dans les outils d'administration du panneau de config ^^
D'ailleurs tu pourras compléter le chemin d'éxécution ainsi que la syntaxe pour bien coller avec l'action lancer par double click

Pour le menu Fichier tu peux faire un send de Alt+f (Send('!f')) et ainsi de suite pour chaque lettre soulignée des autres menus ... (alt+a pour action ...)

sinon Send("{F10}") est correcte , mais il faudra ensuite te déplacer avec les flèches curseurs.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Nicolas
Débutant
Débutant


Nombre de messages : 11
Date d'inscription : 29/05/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-31, 15:44

Sylvanie => En effet ce marche

J'aimerai rendre mon programma moins lourd en utilisaunte boucle 'pour' (for) au lieu de faire send X fois

Je n'ai pas réussi a trouver une synthaxe pour For dans auto it avec Google

si j"ai tenté comme ça comme une synthaxe en Java :

$valeur=0
$max=5

for ($valeur;$valeur<$max;$valeur++)
send ("{TAB}')

Mais auto it ne reconnait pas le ++

Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Probleme pour lancer un menu   2007-05-31, 20:50

send ("{TAB 5}') va envoyer 5 fois TAB, marche aussi pour tout autre touche

cependant sur certaien appli, les 5 ms de pause par envoie de touche est trop rapide, il faut parfois allonger de delai par autoitseroption("SendKeyDelay",valeur)

pour les syntaxe de boucles, et autre, je te conseilles vivement le chm, tout y est ^^, et comme editeur scite for autoit si ce n'est pas déjà le cas

sinon pour le for c'est

for $var=$debut to $fin [ step $pas, optionnel]
....
Next
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Probleme pour lancer un menu   Aujourd'hui à 17:18

Revenir en haut Aller en bas
 
Probleme pour lancer un menu
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» probleme pour lié un menu a une cellule conteneur
» probleme pour center le logo du forum
» probleme pour donner un rang de moderateur
» probleme pour centrer une image défilante
» Probleme pour changer la police du forum ?

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
AutoIt Français :: AutoIt v3 :: Entraide-
Sauter vers: