AutoIt Français

Nouveau forum : http://www.autoitscript.fr/
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexionhttp://www.autoitscript.fr

Partagez | 
 

 Les accents

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
DidUngar
Membre avancé


Nombre de messages : 78
Date d'inscription : 02/04/2007

MessageSujet: Les accents   2007-05-31, 17:45

Voila, je crée un script qui ecrit tous seul en fonction des circonstance.
Comme je fait le script en francais......

Comment on ecrit des accénts ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://didungar.com/
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Les accents   2007-05-31, 20:55

Bonjour,

les accents sont gérés dans les strings normalement ?
tu as un problème sur quel type d'écriture, c'est du filewrite, ou du send ?

sinon tu peux passer par chr(code ascii) ou chrw(code unicode )
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DidUngar
Membre avancé


Nombre de messages : 78
Date d'inscription : 02/04/2007

MessageSujet: Re: Les accents   2007-06-13, 00:07

du send.

J'ecrit un message dans une page web...
Et je valide la page.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://didungar.com/
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Les accents   2007-06-13, 00:10

sur cet exple ils sont bien gérés

run("notepad.exe")
Sleep(1000)
send("éàîë")
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
DidUngar
Membre avancé


Nombre de messages : 78
Date d'inscription : 02/04/2007

MessageSujet: Re: Les accents   2007-06-15, 04:26

Send("Je suis là ,");

Voila la partie du code qui plante.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://didungar.com/
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Les accents   2007-06-15, 11:48

transforme ton (à) en ascii
suis pas sure de la réponse did donc excuse si c'est erroné, je fait avec mes moyens ^^'

[b][i][color=#000090]send[/color][/i][color=#ff0000]([/color][color=#9999cc]"je suis l"[/color][color=#ff0000]&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]224[/color][/i][color=#ff0000])&[/color][color=#9999cc]","[/color][color=#ff0000])[/color][/b]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Les accents   Aujourd'hui à 16:30

Revenir en haut Aller en bas
 
Les accents
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [reglé] Accents qui disparaissent.
» [Résolu] Problème avec les accents sous GM 8.1.
» [Résolu] Linux, texte de saisie et accents
» Problème d'accents horde webmail
» Pas d'accents en HTML ?

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
AutoIt Français :: AutoIt v3 :: Entraide-
Sauter vers: