AutoIt Français

Nouveau forum : http://www.autoitscript.fr/
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexionhttp://www.autoitscript.fr

Partagez | 
 

 Instalation auto

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Instalation auto   2007-06-12, 11:49

Coucou
j'ai un peti souci avec mon code dès la premiere ligne
je ne trouve pas la bonne syntaxe pour lancer mon executable qui se trouve sur un serveur
En fait j'ai bo mettre l'adresse ou il se situe j'ai toujour une erreur
voilà mon code :

Shellexecute,("[color=black]\\chalsr-impres\AgentOcs\\OcsAgentSetup.exe[/color][color=black] ")[/color]
HideAutoItWin, On
WinWaitActive, Installation OCS Inventory
Send, !s
WinWaitActive, Installation OCS Inventory
Send, !c
WinWaitActive, Installation OCS Inventory
Send,10.1.21.15
Send, !s
WinWaitActive, Installation OCS Inventory
Send, !i
Sleep 8000
WinWaitActive, Installation OCS Inventory
Send, !f

Merci si vous voyez mes erreurs
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-12, 12:18

salut jojoe85, vu comme çà c'est de l'autoit V2.

Pour une v3 et non de la v2, çà devrait ressembler a ceux-ci.

[color=#f000ff][i]#NoTrayIcon
[/i][/color][i][color=#009933];Pour OCsAgent il se trouve ou exactement ?
[/color][color=#000090][b]Shellexecute[/b][/color][/i][b][color=#ff0000]([/color][color=#9999cc]"\\chalsr-impres\AgentOcs\OcsAgentSetup.exe "[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'Installation OCS Inventory'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!s'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'Installation OCS Inventory'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!c'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'Installation OCS Inventory'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'10.1.21.15'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!s'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'Installation OCS Inventory'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!i'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Sleep[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][i][color=#ac00a9]8000[/color][/i][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'Installation OCS Inventory'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!f'[/color][/b] [b][color=#ff0000])[/color][/b]


Dernière édition par le 2007-06-12, 12:33, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-12, 12:24

Merci je vais essayer
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-12, 12:46

Il se trouve dans un dossier partagé qui est sur un des serveur
Au fait comment je fais pour que ce soit en silencieu
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-12, 13:26

pour rendre l'excecution en mode invisible et non silencieuse (l'utilitaire windows :msiexec.exe a part çà, je ne vois pas trop pour les install )

[b][i][color=#000090]shellexecute[/color][/i][color=#ff0000]([/color][color=#9999cc]"\\chalsr-impres\AgentOcs\OcsAgentSetup.exe"[/color][color=#ff0000],[/color][color=#9999cc]""[/color][color=#ff0000],[/color][color=#9999cc]""[/color][color=#ff0000],[/color][color=#9999cc]""[/color][color=#ff0000],[/color][color=#ff33ff]@SW_HIDE[/color][color=#ff0000])[/color][/b]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-12, 14:53

merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-12, 15:33

Ca marche pas avec
Shellexecute( 'OcsAgentSetup.exe', ' @SW_HIDE ' )

je doi avoir uin probleme de syntaxe
mais je sais pas lequel
j'ai essayé plusieur truc mai j'ai pas du trouvé le bon
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-12, 16:52

Shellexecute( "OcsAgentSetup.exe","","","",@SW_HIDE)

ShellExecute ( "filename" [, "parameters" [, "workingdir" [, "verb" [, showflag]]]] )

filename = nom du fichier
paramètre = tout parametre du programme sinon laisser blank ""
workingdir = working directory
verb = open,edit, print,properties, ou rien ""
showflag = @sw_hide, @sw_maximize, @sw_minimize


franchement je ne connait pas le shellexecute dans la totalité a part le premier element et le dernier (filename&showflag) les autres j'ai jamais utilisé
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-12, 17:11

Ca marche avec @sw_Minimize mais le hide ne marche pas
serai-ce parce qu'il cache simplement les fenetres DOS mais pas les interface graphique ?
merci bocou pour ton aide
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Instalation auto   2007-06-12, 22:51

Pour @SW_HIDE, c'est indépendant du type de fenêtre
pour ShellExecute , quel est le code de retours de la fonction quand tu es dans ce mode ?

ps : peut on bouger ce post qui devrait être dans entraide et non ici ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-13, 14:48

[quote]ps : peut on bouger ce post qui devrait être dans entraide et non ici ?[/quote]

non , pas le pouvoir, mais un msg fut envoyé

pour le hide j'ai testé sur scite "en exemple" est ca ne fonctionne evidement pas, faudrait passer par un wingethandle suivit d'un winsetstate (hide) mais vu mon bagage (vide) je ne n'arrive pas a concevoir celà, merci d'avance pour les plus doué.

excuse moi jojoe85
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-13, 15:24

merci quan meme je vais essayer de chercher

et désolé d'avoir poster au mauvais endroit
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-13, 16:15

je me demande si c'est pas le titre qui ferait defaut, comme c'est pas le premier a se tromper

est-ce celà jojoe85?

bon bein je retourne au menage ..
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-13, 16:37

En fait ca y es g reussi a le mettre en silencieux en créant compilant mon .au3 en .exe puis en le mettant dans un .bat et en mettant /s

mais maintenant il ecrit pas les chiffre avec le pavé numérique mais avec les touches au dessus des lettres

mais il est pas en majuscule donc au lieu d'avoir 10.1.21.15 j'ai &à;&;é&;&( donc aurai tu une idée pour bloqué les majuscules ou pour qu'il tape avec le pavé numérique?

merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-13, 17:15

en mettant un S alors ca pourrait fonctionner avec shellexecute ou meme run faudrait voir avec les specialistes ^^'

le capslock = send("{CAPSLOCK}")
ps: j'ai testé le capslock il se delock automatiquement , fonctionne pas chez moi

pour l'ip transforme la en chr(ascii)
exemple ::

[b][color=#aa0000]$ip[/color][/b] [b][color=#ff0000]=[/color][/b] [b][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]48[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]50[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]53[/color][/i][color=#ff0000])[/color][/b]

[b]send[/b][color=red]([/color][b][color=#aa0000]$ip[/color][/b][color=red])[/color]

[u]info ascii[/u]
chr(49) = 1 ... chr(48 = 0 ... chr(46) = .
chr(50) = 2 ... chr(53) = 5
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-13, 17:41

merci merci merci
c cool tout marche
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
sylvanie
Modérateur
Modérateur


Nombre de messages : 300
Date d'inscription : 10/03/2007

MessageSujet: Re: Instalation auto   2007-06-13, 19:53

kikou tout le monde !
Bon , j'arrive après la bataille; mais en ce qui concerne le fait de cacher Scite par exple, ça marche avec ce script :
AutoItSetOption("WinTitleMatchMode",2)

$title="- SciTE"
$title=WinGetTitle($title,"")
ConsoleWrite($title)
WinSetState($title,"",@SW_HIDE)
Sleep(1000)
WinSetState($title,"",@SW_SHOW)


c'était juste histoire de dire que c'était possible ^^
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-14, 01:19

et voilà j'oublie le titre ^^'
je passait par wingethandle evidement c'était pas top

donc voilà une soluce vu que le titre ne change pas du début à la fin de l'install.

donc au lieu du send faut utiliser controlsend ?
maintenant que tout le monde fait des install j'ai envie aussi ^^' enifn c'est mon histoire de novice ...mais quoi installer
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-14, 17:27

salut
sa va ?
en fait ca ne marche pas le silence
es que tu pourrai m'expliquer un peu plus ton code
je sais pas ou le mettre ni ce sue je dois remplacer
merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: Instalation auto   2007-06-14, 18:23

[i][color=#f000ff]#NoTrayIcon
[/color][color=#000090][b]AutoItSetOption[/b][/color][/i][b][color=#ff0000]([/color][color=#9999cc]"WinTitleMatchMode"[/color][color=#ff0000],[/color][i][color=#ac00a9]2[/color][/i][/b][b][color=#ff0000])

[/color][color=#aa0000]$ip[/color][/b] [b][color=#ff0000]=[/color][/b] [b][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]48[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]50[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]46[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]49[/color][/i][color=#ff0000])&[/color][i][color=#000090]chr[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]53[/color][/i][/b][b][color=#ff0000])
[/color][color=#aa0000]$title[/color][color=#ff0000]=[/color][/b][b][color=#9999cc]"Installation OCS Inventory"
[/color][color=#aa0000]$title[/color][color=#ff0000]=[/color][i][color=#000090]WinGetTitle[/color][/i][color=#ff0000]([/color][color=#aa0000]$title[/color][color=#ff0000],[/color][color=#9999cc]""[/color][/b][b][color=#ff0000])

[/color][i][color=#000090]Shellexecute[/color][/i][color=#ff0000]([/color][color=#9999cc]"OcsAgentSetup.exe"[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]WinSetState[/color][/i][color=#ff0000]([/color][color=#aa0000]$title[/color][color=#ff0000],[/color][color=#9999cc]""[/color][color=#ff0000],[/color][color=#ff33ff]@SW_HIDE[/color][/b][b][color=#ff0000])

[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$title[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!s'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$title[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!c'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$title[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$ip[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!s'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$title[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!i'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]Sleep[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][i][color=#ac00a9]8000[/color][/i][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinWaitActive[/color][/i][/b] [b][color=#ff0000]([/color][color=#aa0000]$title[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]Send[/color][/i][/b] [b][color=#ff0000]([/color][/b] [b][color=#9999cc]'!f'[/color][/b] [b][color=#ff0000])
[/color][i][color=#000090]WinSetState[/color][/i][color=#ff0000]([/color][color=#aa0000]$title[/color][color=#ff0000],[/color][color=#9999cc]""[/color][color=#ff0000],[/color][color=#ff33ff]@SW_show[/color][/b][b][color=#ff0000])
[/color][i][color=#000090]msgbox[/color][/i][color=#ff0000]([/color][i][color=#ac00a9]0[/color][/i][color=#ff0000],[/color][color=#aa0000]$title[/color][color=#ff0000],[/color][color=#9999cc]"votre installation est terminé"[/color][color=#ff0000],[/color][i][color=#ac00a9]5[/color][/i][color=#ff0000])[/color][/b]

Normalement ca devrait ressembler a ceux-ci
Mais vu que je suis novice te fit pas trop ^^'
Sinon ce logiciel sous dos dispose t'il de cmd ?
ps: je rentre chez moi a touti
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jojoe85
Débutant
Débutant


Nombre de messages : 12
Age : 32
Localisation : Vendée
Date d'inscription : 12/06/2007

MessageSujet: Re: Instalation auto   2007-06-20, 12:03

merci beaucoup
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Instalation auto   Aujourd'hui à 08:42

Revenir en haut Aller en bas
 
Instalation auto
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Auto-Installation Numéricable!!
» ZUMO 660 option auto / moto
» Problème d'instalation de thème
» Auto-délestage
» Auto-sabordage

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
AutoIt Français :: AutoIt v3 :: Entraide-
Sauter vers: