AutoIt Français

Nouveau forum : http://www.autoitscript.fr/
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexionhttp://www.autoitscript.fr

Partagez | 
 

 (RESOLU)_Probleme d'instruction_(RESOLU)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-08, 12:10

Etant novice de chez novice avenue, enfin bon vous le savez déjà (rien qu'a regarder le code on a compris )

Descriptif: Effet de transition par menu (transparence..)

[color=red]#include[/color]
opt ( "GUIOnEventMode" , 1 )
Global const [color=mediumblue]$szVersion[/color] = "0.0.0.1"
;Création de l'interface [color=mediumblue]$GUI[/color] = GUICreate ( "WinSetTrans_Exemple by autoit-Fr" , 298 , 198 , 225 , 147 )
GUISetOnEvent ( [color=mediumblue]$GUI_EVENT_CLOSE[/color] , "_Effetout" )
; Menu Contextuel de l'interface
[color=mediumblue]$Guicontext[/color] = GUICtrlCreateContextMenu ( )
[color=mediumblue]$MenuC_Opaque[/color] = GUICtrlCreateMenu ( "Opacité" , [color=mediumblue]$Guicontext[/color] )
; création des sous menus pour la transition vers la transparence
for [color=mediumblue]$MENUC_TRANSIT[/color] = 1 to 10
GUICtrlCreateMenuItem ( [color=mediumblue]$MENUC_TRANSIT*10[/color] &" %" , [color=mediumblue]$MenuC_Opaque[/color] )
Next
[color=mediumblue]$MenuC_quitter[/color] = GUICtrlCreateMenuItem ( "Fermer" , [color=mediumblue]$Guicontext[/color] )
GUICtrlSetOnEvent ( [color=mediumblue]$MENUC_Quitter[/color] , "_Effetout" )
; Menu et sous menu de l'interface
[color=mediumblue]$MenuI[/color] = GUICtrlCreateMenu ( "&Menu" )
[color=mediumblue]$MenuI_Opaque[/color] = GUICtrlCreateMenu ( "Opacité" , [color=mediumblue]$MenuI[/color] )
; création des sous menus pour la transition vers la transparence
for [color=mediumblue]$MENUI_TRANSIT[/color] = 1 to 10
GUICtrlCreateMenuItem ( [color=mediumblue]$MENUI_TRANSIT*10[/color] &" %" , [color=mediumblue]$MenuI_Opaque[/color] )
Next
[color=mediumblue]$MENUI_Quitter[/color] = GUICtrlCreateMenuItem ( "Fermer" , [color=mediumblue]$MENUI[/color] )
GUICtrlSetOnEvent ( [color=mediumblue]$MENUI_Quitter[/color] , "_Effetout" )
GUISetState ( [color=fuchsia]@SW_SHOW[/color] )
[color=green]while[/color] 1
sleep ( 1000 )
[color=green]WEnd[/color]
; Cette fonction peut remplacer l'effet Fade-out ( user32.dll / AW_FADE_OUT = 0x00090000 )
; elle sert ici pour la fermeture du programme.
Func _Effetout ( )
for [color=mediumblue]$VALEUR_X[/color] = 255 to 0 step -1
WinSetTrans ( "" , "" , [color=mediumblue]$VALEUR_X[/color] )
Next
exit
EndFunc



le problème c'est que je voudrai appliquer l'effet winsettrans sur les menus (sachant qu'a 10 pourcent c'est à 25.5), mais je vois pas comment, un indice la dessus , merci

au niveau de la syntaxe c'est juste ? ou y a quelque chose a changer

merci pour l'aide apporté et merci d'avance au correcteur


vais continuer a lire les includes .


Dernière édition par le 2007-03-08, 05:50, édité 7 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Dragonsayen
Débutant
Débutant


Nombre de messages : 18
Age : 26
Localisation : Auray (Morbihan)
Date d'inscription : 10/12/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-08, 15:58

tu n'es pas obligés de déclarer les variables (ça te facilitera la tache ^^)
utilise dim juste pour les matrices (les tableaux) (array)

juste une question :
tu voulais faire quoi exactement avec la fonction : ShellExecute($URL_FORUM_FR) ? (la fonction shellexecute n'existe pas dans autoit)

sinon j'aime bien cette idée ^^ une fois je voulais faire cela mais pour toute les fenetres en générale (en rajoutant des options avec le registre par exemple). mais je l'ai jamais fait et je suis passé sur autre chose ^^
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.riseoflords.com/?seigneur=dragonsayan
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-08, 16:51

j'ai pourtant bien lu la documentation.

shellexecute existe sous win aussi.

Au niveau d'autoit voilà au lieu d'utiliser la commande run(IE.au3), j'ai préféré mettre shellexecute

[size=16]ShellExecute[/size]

Runs an external program using the ShellExecute API.

ShellExecute ( "filename" [, "parameters" [, "workingdir" [, "verb" [, showflag]]]] )

[b]Parameters[/b]

filename
The name of the file to run (EXE, .txt, .lnk, etc).


dans la variable j'avais mis ceux-ci
Global Const $URL_FORUM_FR = " http://autoit-fr.realbb.net/index.htm"

et au niveau du while je rajoute le select
case $msg = $MenuI_Forum
ShellExecute($URL_FORUM_FR)

il load directement la page, mais c'est pas çà que je désire, il serait mieux qu'il le charge dans une nouvelle fenetre mais j'ai pas encore trouvé, pas évident... sauf avec run(ie.au3) y juste a creer la page.

Donc je devrai retirer les variables du début tu parle bien de celle-ci :
$valeur_X ="0"
$start = "0"
$stop= "255"
.....

et d'indiquer à la place GuiCtrlSetData ?


Dernière édition par le 2007-02-10, 17:29, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Dragonsayen
Débutant
Débutant


Nombre de messages : 18
Age : 26
Localisation : Auray (Morbihan)
Date d'inscription : 10/12/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-08, 16:58

tiens, tu as quel version d'autoit ? je dois pas etre à jour alors ... (ou j'ai zappé quelque chose) (sinon je connaissais shellexecute, mais pas avec autoit ^^)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.riseoflords.com/?seigneur=dragonsayan
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-08, 17:03

la derniere version, 3.2.0.0
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-09, 12:12

personne ?

sinon dragon c'est en projet, l'histoire de la transparence.
en faite j'essaie de comprendre l'interface (avec tout ce quelle comporte).

puis on m' dit que je pourrait pas creer de composant dll avec autoit (donc je cherche, j'ai vb6 mais jamais testé).

bon je cherche comment faire cette procedure

for $MENUI_TRANSIT = 1 to 10
GUICtrlCreateMenuItem($MENUI_TRANSIT*10 &" %", $MenuI_Opaque)
Next

la ca cree bien 10 menu avec comme label 10 a 100 % manque le check et lui assigner la valeur de transparence qui correspond a chaque menu.

pas evident, meme que les procedure de boucle je comprend pas trop a quel moment on les met si c'est switch ou else ou if un peu de mal, enfin bon ca va venir (j'espere)

merci.

longue vie a autoit-fr
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-09, 13:01

en voyant la fonction winsettrans et for $x = <start> to <stop> , je me demandais si on pouvait realiser un dégradé directement ?

j'ai bien essayé avec les moyens dont je dispose qui veut dire pas grand chose ...()

$a = 0x1010ff
$b = 0x8080ff
$x = ""
for $x = $a to $b
winsettrans ("","",$x)
next
GUICtrlSetBkColor($x)


a pas tester sinon vous etes bon a relancer toute vos interface.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-17, 14:50

bon j'ai retourné dans tout les sens, j'ai rien trouvé, juste abandonné .. dommage de bloquer sur un petit truc comme çà :§
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-20, 14:56

Voilà le menu marche pour changer la transparence de la fenêtre...

et que de la fenêtre,car winsettrans ne marche que pour ça et non pour les menus,qui seront visibles à 100% lorsqu'on clique dessus.

Là je pense pas que tu puisse y faire quelque chose,car on doit quand pouvoir voir le menu pour rechanger la visibilité si on en voit plus rien.

[color=Red]#include[/color] <GUIConstants.au3>
Global Const [color=MediumBlue]$szVersion[/color] [color=Green]=[/color] "0.0.0.1"
;Création de l'interface
[color=MediumBlue]$GUI[/color] [color=Green]=[/color] [b]GUICreate[/b] ( "[b]WinSetTrans_Exemple[/b] by autoit + Fr" [color=Green],[/color] 298 [color=Green],[/color] 198 [color=Green],[/color] 225 [color=Green],[/color] 147 )
; Menu Contextuel de l'interface
[color=MediumBlue]$Guicontext[/color] [color=Green]=[/color] [b]GUICtrlCreateContextMenu[/b] ( )
[color=MediumBlue]$MenuC_Opaque[/color] [color=Green]=[/color] [b]GUICtrlCreateMenu[/b] ( "Opacité" [color=Green],[/color] [color=MediumBlue]$Guicontext[/color] )
; création des sous menus pour la transition vers la transparence
[color=Green]For[/color] [color=MediumBlue]$MENUC_TRANSIT[/color] [color=Green]=[/color] 1 [color=Green]To[/color] 10
[b]GUICtrlCreateMenuitem[/b] ( [color=MediumBlue]$MENUC_TRANSIT[/color] * 10 [color=Green]&[/color] " %" [color=Green],[/color] [color=MediumBlue]$MenuC_Opaque[/color] )
[color=Green]Next[/color]
[color=MediumBlue]$MenuC_quitter[/color] [color=Green]=[/color] [b]GUICtrlCreateMenuitem[/b] ( "Fermer" [color=Green],[/color] [color=MediumBlue]$Guicontext[/color] )
; Menu et sous menu de l'interface
[color=MediumBlue]$MenuI[/color] [color=Green]=[/color] [b]GUICtrlCreateMenu[/b] ( "[color=Green]&Menu"[/color] )
[color=MediumBlue]$MenuI_Opaque[/color] [color=Green]=[/color] [b]GUICtrlCreateMenu[/b] ( "Opacité" [color=Green],[/color] [color=MediumBlue]$MenuI[/color] )
; création des sous menus pour la transition vers la transparence
[b]Dim[/b] [color=MediumBlue]$_array[11][/color]
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 1 [color=Green]To[/color] 10
[color=MediumBlue]$_array[$i][/color] [color=Green]=[/color] [b]GUICtrlCreateMenuitem[/b] ( [color=MediumBlue]$i[/color] * 10 [color=Green]&[/color] " %" [color=Green],[/color] [color=MediumBlue]$MenuI_Opaque[/color] )
[color=Green]Next[/color]
[color=MediumBlue]$MENUI_Quitter[/color] [color=Green]=[/color] [b]GUICtrlCreateMenuitem[/b] ( "Fermer" [color=Green],[/color] [color=MediumBlue]$MenuI[/color] )
[b]GUISetState[/b] ( [color=Fuchsia]@SW_SHOW[/color] )
[color=Green]While[/color] 1
[color=MediumBlue]$msg[/color] [color=Green]=[/color] [b]GUIGetMsg[/b] ( )
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$GUI_EVENT_CLOSE[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MenuC_quitter[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MENUI_Quitter[/color] [color=Green]Then[/color] effet ( )
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 1 [color=Green]To[/color] 10
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array[$i][/color] [color=Green]Then[/color] abc ( [color=MediumBlue]$i/10*255[/color] )
[color=Green]Next[/color]
[color=Green]WEnd[/color]
; Cette fonction peut remplacer l'effet Fade + out ( user32.dll / AW_FADE_OUT [color=Green]=[/color] 0x00090000 )
; elle sert ici pour la fermeture du programme.
[color=Green]Func[/color] abc ( [color=MediumBlue]$valeur[/color] )
[b]WinSetTrans[/b] ( "[b]WinSetTrans_Exemple[/b] by autoit + Fr" [color=Green],[/color] "" [color=Green],[/color] [color=MediumBlue]$valeur[/color] )
[color=Green]EndFunc[/color]
[color=Green]Func[/color] effet ( )
[color=Green]For[/color] [color=MediumBlue]$VALEUR_X[/color] [color=Green]=[/color] 255 [color=Green]To[/color] 0 Step + 1
[b]WinSetTrans[/b] ( "[b]WinSetTrans_Exemple[/b] by autoit + Fr" [color=Green],[/color] "" [color=Green],[/color] [color=MediumBlue]$VALEUR_X[/color] )
[color=Green]Next[/color]
[b]Exit[/b]
[color=Green]EndFunc[/color] ; [color=Green]=[/color] [color=Green]=[/color] >effet [color=Red][/color]

[color=red][/color][color=Red][/color]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-21, 18:20

oui, oui, les menus doivent etre visible, c'est bien çà

a voir comme çà y a un seul sous menu qui fonctionne :p

grand merci vais essayé car j'ai pas bien suivit
la func abc($valeur) elle est aléatoire ?
et $_array[11] dans le for y a 10 nombre seulement vu que tu débute pas a zero ou j'ai pas suivit

l'exemple de la transparence et bientôt end
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-21, 19:04

[quote:daf2="ani"]oui, oui, les menus doivent etre visible, c'est bien çà

a voir comme çà y a un seul sous menu qui fonctionne :p

grand merci vais essayé car j'ai pas bien suivit
la func abc($valeur) elle est aléatoire ?
et $_array[11] dans le for y a 10 nombre seulement vu que tu débute pas a zero ou j'ai pas suivit

l'exemple de la transparence et bientôt end :)[/quote]

Pour abc() tu peux directement mettre winsettrans()
C'était pour ne pas surcharger la ligne.

Comme j'ai besoin d'une boucle de 1 à 10 ( pour que $i multiplie le 10)
je dois aussi utiliser des arrays de 1 à 10,et comme la première array est 0,
il faut la définir à 11.
Si tu veux définir avec 10 :
[b]Dim[/b] [color=MediumBlue]$_array[10][/color]
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 0 [color=Green]To[/color] 9
[color=MediumBlue]$_array[$i][/color] [color=Green]=[/color] [b]GUICtrlCreateMenuitem[/b] ( ( [color=MediumBlue]$i[/color] + 1 ) * 10 [color=Green]&[/color] " %" [color=Green],[/color] [color=MediumBlue]$MenuI_Opaque[/color] )
[color=Green]Next[/color]
[color=MediumBlue]$MENUI_Quitter[/color] [color=Green]=[/color] [b]GUICtrlCreateMenuitem[/b] ( "Fermer" [color=Green],[/color] [color=MediumBlue]$MenuI[/color] )
[b]GUISetState[/b] ( [color=Fuchsia]@SW_SHOW[/color] )
[color=Green]While[/color] 1
[color=MediumBlue]$msg[/color] [color=Green]=[/color] [b]GUIGetMsg[/b] ( )
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$GUI_EVENT_CLOSE[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MenuC_quitter[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MENUI_Quitter[/color] [color=Green]Then[/color] effet ( )
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 0 [color=Green]To[/color] 9
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array[$i][/color] [color=Green]Then[/color] abc ( ( [color=MediumBlue]$i[/color] + 1 ) / 10 * 255 )
[color=Green]Next[/color]
[color=Green]WEnd[/color]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-21, 19:36

j'avais testé mais une erreur est apparu ^^
c'est pour les lecteurs

même si la petite pièce n'est pas encore tombé, vais comprendre

là j'imagine autre chose, vu que le menu de transparence apparait dans deux menu séparé l'un lors du click et l'autre au niveau de l'interface, je me suis posé la question de cree une simple fonction qui creerait automatiquement (comme precedement) dans chaque menu la meme fonction.

suis pas sure d'être clair
; menu/sous menu
opak()

func Opak()
$TRANSPARENT = GUICtrlCreateMenu("Opacité")
for $Sous_menu = 1 to 10
GUICtrlCreateMenuItem($Sous_menu * 10 & "%", $TRANSPARENT)
next
endfunc

vais essayer de bidouiller çà avec ta fonction a mon avis là il creera juste le menu sur l(interface et non dans le menu du click
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-21, 23:30

Euh et l'erreur c'est quoi?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-22, 01:36

au niveau du dim array[](ligne 17) j'avais noté 10 et voici l'erreur

Array variable has incorrect number of subscripts or subscript dimension range exceeded.: et il m'indique en ligne 19 $_array[$i] ^ ERROR


bon j'ai pas avancé
je retourne a la fonction

encore merci adminterminator


j'ai essay" de creer cette fonction mais sans succés j'ai quand meme une question

j'ai l'impression que le premier code s'excecute plus vite que le second est-ce une idée ?

[color=Green]While[/color] 1
[color=MediumBlue]$msg[/color] [color=Green]=[/color] [b]GUIGetMsg[/b] ( )
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$GUI_EVENT_CLOSE[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MenuC_quitter[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MENUI_Quitter[/color] [color=Green]Then[/color] effet ( )
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 1 [color=Green]To[/color] 10
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array0[$i][/color] [color=Green]Then[/color] abc ( [color=MediumBlue]$i/10*255[/color] )
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array1[$i][/color] [color=Green]Then[/color] abc ( [color=MediumBlue]$i/10*255[/color] )
[color=Green]Next[/color]
[color=Green]WEnd[/color]


[b]Second[/b]

[color=Green]While[/color] 1
[color=MediumBlue]$msg[/color] [color=Green]=[/color] [b]GUIGetMsg[/b] ( )
[b]select[/b]
case [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$GUI_EVENT_CLOSE[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MenuC_quitter[/color] Or [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$MENUI_Quitter[/color]
effet ( )
endselect
[color=Green]For[/color] [color=MediumBlue]$i[/color] [color=Green]=[/color] 1 [color=Green]To[/color] 10
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array0[$i][/color] [color=Green]Then[/color] abc ( [color=MediumBlue]$i/10*255[/color] )
[color=Green]If[/color] [color=MediumBlue]$msg[/color] [color=Green]=[/color] [color=MediumBlue]$_array1[$i][/color] [color=Green]Then[/color] abc ( [color=MediumBlue]$i/10*255[/color] )
[color=Green]Next[/color]
[color=Green]WEnd[/color]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-22, 23:25

Oui,un select est une implémentation de if.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-23, 22:40

Sinon tu bloque encore sur une fonction?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-24, 00:21

Pour faire jolie manquerai plus que le checked , mais là j'en demande trop

t'aurai pas une petite fonction qui permet de visualiser le temp de réaction d'un évènement ?

ou un petit exemple

*
merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-27, 03:32

Héhé j'ai un truc vachement précis dans mes archives de favoris... [url=http://www.autoitscript.com/forum/index.php?showtopic=38751&st=0&p=288692&#entry288692]http://www.autoitscript.com/forum/index.php?showtopic=38751&st=0&p=288692&#entry288692[/url]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-02-27, 12:48

suis pas fort doué , même en faisant un copié collé, çà marche pas ^^' .

je vais déjà finir la fonction et vous soumettre en mp le script (pour de petite correction et voir si on peut faire des suites de ce genre)

merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-03-01, 17:40

n'ayant toujours pas réussi a mettre le checked ca restera ainsi ..
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-03-01, 17:46

tu peux m'envoyer ton script et me dire où ça cloche...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-03-01, 18:30

(b_d) tu va rire .... je viend d'effacer tout un dossier et c'est dans cette endroit ou je met les script .... rhaaa enfin vais refaire çà vite fait avec ceux qui est noté sur le post :p

avec la fonction du click creation de sous menu j'arrive pas a checked j'ai meme abandonné l'histoire du flash pour cette exemple ... ej t'envoi le plus vite possible (faudra un peu de temp ej débute moi )


thx a lot :p
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
TerminAdminAtor
Admin
Admin


Nombre de messages : 234
Date d'inscription : 22/10/2006

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-03-01, 22:22

Voilà ça devrait être bon, [url=http://ibanker.ifrance.com/autoit3/WinSetTrans.au3]>lien[/url]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://autoit-fr.realbb.net
ani
Modérateur
Modérateur


Nombre de messages : 563
Date d'inscription : 23/01/2007

MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   2007-03-02, 01:47

j'aurai jamais trouvé la manière de procéder pour ce checked.
vais poster script ^^'

Grand grand merci.

PS : le titre est telement long que le [resolu] se verra pas je m'édite sur le titre si pas delete le post (attend avant, que je note tout) .

le depot que tu utilise on peut aussi ?
ou je fait un post pour tout les script (je finiole le tout) ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: (RESOLU)_Probleme d'instruction_(RESOLU)   Aujourd'hui à 22:45

Revenir en haut Aller en bas
 
(RESOLU)_Probleme d'instruction_(RESOLU)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Roll-over (Resolu)
» icone(RESOLU par Migau)
» Le message ne se postent pas...[RESOLU]
» [RESOLU] Bidouillage
» Modérateurs couleur groupe RESOLU

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
AutoIt Français :: AutoIt v3 :: Entraide-
Sauter vers: